exchange服务器之Currency Exchange--(最短路径算法)
白羽 2018-12-11 来源 :网络 阅读 1590 评论 0

摘要:本文将带你了解exchange服务器之Currency Exchange--(最短路径算法),希望本文对大家学Exchange有所帮助。

    本文将带你了解exchange服务器之Currency Exchange--(最短路径算法),希望本文对大家学Exchange有所帮助。


Currency Exchange
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 74   Accepted Submission(s) : 19
Problem Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
 

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10<sup>3</sup>. <br>For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10<sup>-2</sup><=rate<=10<sup>2</sup>, 0<=commission<=10<sup>2</sup>. <br>Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10<sup>4</sup>. <br>
 

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
 

Sample Input

3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00
 

Sample Output

YES

用Bellman算法若能求出一个正权回路,那么货币经转化会越来越大

代码(Bellman-Ford):

    #include<iostream>
    #include<string>
    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<iomanip>
    #include<queue>
    #include<cstring>
    using namespace std;
    struct node{
        int a,b;
        double r,c;
    }p[205];
    int n,m,s;
    double v,dis[105];
    int main()
    {
        int i,j,a,b;
        double r1,c1,r2,c2;
        scanf("%d%d%d%lf",&n,&m,&s,&v);
        for(i=1;i<=m;i++)  //n个exchange point化为2*m个边
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&r1,&c1,&r2,&c2);
            p[i].a=a; p[i].b=b; p[i].r=r1; p[i].c=c1;
            p[i+m].a=b; p[i+m].b=a; p[i+m].r=r2; p[i+m].c=c2;
        }
        for(i=1;i<=n-1;i++)
            dis[i]=0;
        dis[s]=v;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=2*m;j++)
            {
                double w=(dis[p[j].a]-p[j].c)*p[j].r;
                if(w>dis[p[j].b]) {dis[p[j].b]=w;}
            }
        }
        bool flag=false;
        for(i=1;i<=2*m;i++)
        {
            double w=(dis[p[i].a]-p[i].c)*p[i].r;
            if(w>dis[p[i].b]) {flag=true; break;}  //存在正权回路
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
        return 0;
    }


本文由职坐标整理并发布,希望对同学们有所帮助。了解更多详情请关注职坐标系统运维之Exchange频道!

本文由 @白羽 发布于职坐标。未经许可,禁止转载。
喜欢 | 0 不喜欢 | 0
看完这篇文章有何感觉?已经有0人表态,0%的人喜欢 快给朋友分享吧~
评论(0)
后参与评论

您输入的评论内容中包含违禁敏感词

我知道了

助您圆梦职场 匹配合适岗位
验证码手机号,获得海同独家IT培训资料
选择就业方向:
人工智能物联网
大数据开发/分析
人工智能Python
Java全栈开发
WEB前端+H5

请输入正确的手机号码

请输入正确的验证码

获取验证码

您今天的短信下发次数太多了,明天再试试吧!

提交

我们会在第一时间安排职业规划师联系您!

您也可以联系我们的职业规划师咨询:

小职老师的微信号:z_zhizuobiao
小职老师的微信号:z_zhizuobiao

版权所有 职坐标-一站式IT培训就业服务领导者 沪ICP备13042190号-4
上海海同信息科技有限公司 Copyright ©2015 www.zhizuobiao.com,All Rights Reserved.
 沪公网安备 31011502005948号    

©2015 www.zhizuobiao.com All Rights Reserved

208小时内训课程